CamBam
News:
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
February 22, 2020, 07:26:53 am


Login with username, password and session length


Pages: [1] 2 3
  Print  
Author Topic: CamBam plus V1.0 (rc-1)  (Read 3600 times)
10bulls
Administrator
CNC Jedi
*****
Offline Offline

Posts: 2133


Coding Jedi


View Profile WWW
« on: September 24, 2019, 13:10:10 pm »

A new CamBam release V1.0 (rc-1) is available...

http://cambamcnc.com/downloads/#devt

Release notes...

This release is also available for Linux and Raspberry pi (there have been a number of linux bug fixes in this release)...

http://cambamcnc.com/ref/ref.linux

The rc-1 tag denotes 'release candidate', which implies that, at long last, we nearing the point of making V1.0 the recommended production release.

The main aim of this release has been to work through remaining bugs and issues, particularly where these prevented moving over from 0.9.8

If you are yet to try V1.0 we recommend doing so.
If there are issues with this release preventing you from moving from 0.9.8, please let us know!

Note, V1.0 and 0.9.8 can be installed on the same computer and run in parallel.
Version 1.0 now requires the .NET framework version 4 to installed.

Thank you again for your support, feedback and patience while we work to make this the best CamBam release yet!

Regards

Andy Payne (10bulls)
« Last Edit: September 24, 2019, 13:12:10 pm by 10bulls » Logged
10bulls
Administrator
CNC Jedi
*****
Offline Offline

Posts: 2133


Coding Jedi


View Profile WWW
« Reply #1 on: September 24, 2019, 13:10:42 pm »

Windows 10 may unfortuntely block the latest installer with a
"Windows protected your PC" message.

If you click 'More Info', then 'Run anyway' the installation will continue as normal.

We recently renewed our code signing certifcate, but unfortunately the 'trust'
built up from the old expired certificate has been reset.
Eventually this message should go away as more people install the new version
and smartscreen aquires 'trust' in the renewed certificate.

Logged
EL34
CNC Jedi
*****
Offline Offline

Posts: 754


View Profile WWW
« Reply #2 on: September 24, 2019, 13:16:59 pm »

Thanks Andy
Long time no talk

I am still using Cambam
Logged

Mach 3, Cambam, Autodesk Quickcad 8, machine info -> http://www.el34world.com/Misc/Cnc/CNC0.htm
pixelmaker
CNC Jedi
*****
Offline Offline

Posts: 1724


View Profile WWW
« Reply #3 on: September 24, 2019, 13:18:34 pm »

Fantastic! Thank you Andy!

ralf
Logged
10bulls
Administrator
CNC Jedi
*****
Offline Offline

Posts: 2133


Coding Jedi


View Profile WWW
« Reply #4 on: September 24, 2019, 13:51:56 pm »

Long time no talk
Yes, much too long sorry.  Getting back on top of things again though.
Quote
I am still using Cambam
Yay!  Me Too!  Grin  ...what else would we be using?  Huh

Fantastic! Thank you Andy!
You are very welcome Ralf!  Hopefully some of the bugs you spotted should be tackled in this release... sorry it took so long.
Logged
Dragonfly
CNC Jedi
*****
Offline Offline

Posts: 2253



View Profile
« Reply #5 on: September 24, 2019, 15:16:57 pm »

Good news finally Smiley

On Ubuntu 16.04. Mono is frozen at ver. 5.12.0 because after that Main menu texts were displayed with large font size.

Plugins causing crash:
Num Move - crashes out CB without prompt when selected from context menu. When selected from main menu brings out file save before exit dialog.
Fillet/Chamfer   - brings out file save before exit.
In both cases the work file is in unsaved state.


Snappy - OK
Aligner - OK
Point add/delete - OK
Measure XYZ - OK
Extender - OK
Flatten - OK
Show Extrema - OK
File Import - OK
 
« Last Edit: September 24, 2019, 15:30:15 pm by Dragonfly » Logged
dh42
Administrator
CNC Jedi
*****
Offline Offline

Posts: 5756



View Profile WWW
« Reply #6 on: September 24, 2019, 18:27:53 pm »

Hello

For the 2 plugins that cause problem, you can try this:

sudo apt-get install libmono-microsoft-visualbasic10.0-ci

If I well remember, I need to run this command each time I change the CB version if I want that the plugins written in VB works (only for those that use a "form")

++
David
Logged
Dragonfly
CNC Jedi
*****
Offline Offline

Posts: 2253



View Profile
« Reply #7 on: September 24, 2019, 18:39:17 pm »

It's installed. And everything was working a few hours ago (with the limitation that NumMove does not remember current entered values after closing). I simply unpacked the new .rc  version deleting the previous folders. Confirmed that CB is starting and then copied back the plugins which were in use up to that moment.
As I pointed I am using mono 5.12.0. But  libmono-microsoft-visualbasic10.0-ci has not been updated and is version 4.7.
Don't know whether it has been upgraded in the newer releases (current is 6.4.0) but after 5.12.0 the main menus in CB became very ugly so I rolled back.
« Last Edit: September 24, 2019, 18:44:46 pm by Dragonfly » Logged
dh42
Administrator
CNC Jedi
*****
Offline Offline

Posts: 5756



View Profile WWW
« Reply #8 on: September 24, 2019, 19:01:43 pm »

Just tried on Ubuntu 14.04, and both plugin are working (without using the sudo ...)

++
David
Logged
lloydsp
CNC Jedi
*****
Offline Offline

Posts: 8138



View Profile
« Reply #9 on: September 24, 2019, 19:12:24 pm »

Andy,
It's running fine (on XP, no less!), but I noticed a 'deficiency' in the print function that existed in the old version.

There's no provision for 'fit to page size', which even my old, decrepit plugin had.  Can you add that feature?

Thanks for all your work.

Yours,
Lloyd
Logged

"Pyro for Fun and Profit for More Than Fifty Years"
dh42
Administrator
CNC Jedi
*****
Offline Offline

Posts: 5756



View Profile WWW
« Reply #10 on: September 24, 2019, 19:17:39 pm »

Hello Lloyd

I think you can use " To Fit" in the context menu.

http://www.cambam.info/doc/dw/1.0.0/file-menu.html#print-

++
David
Logged
lloydsp
CNC Jedi
*****
Offline Offline

Posts: 8138



View Profile
« Reply #11 on: September 24, 2019, 19:40:38 pm »

Thank you, David!

There wasn't any evidence of that in the toolbar, and I didn't even attempt to right-click on the view.

It works fine!

Sorry, Andy... my fault!

But... I might 'contend' that a particular view should automatically fit the selected page size, without having to select an option to get it there.  Mine didn't do that either, but had a main menu option, where it was - eh - more visible.

Thanks, all!
Lloyd
Logged

"Pyro for Fun and Profit for More Than Fifty Years"
Dragonfly
CNC Jedi
*****
Offline Offline

Posts: 2253



View Profile
« Reply #12 on: September 24, 2019, 20:16:25 pm »

Just tried on Ubuntu 14.04, and both plugin are working (without using the sudo ...)

++
David

Terribly sorry David,
False alarm.  I forgot that there is a version for Linux and copied the plugins from the windows installation.
 Cry

NumMove and Fillet/Chamfer (special versions for Linux) - OK
« Last Edit: September 24, 2019, 20:26:42 pm by Dragonfly » Logged
dh42
Administrator
CNC Jedi
*****
Offline Offline

Posts: 5756



View Profile WWW
« Reply #13 on: September 24, 2019, 20:16:43 pm »

Re

@Andy

I don't know if it is the case for all Linux versions, but in the ubuntu14-32 bits package, the Help folder is missing !

++
David

Edit: Help folder is missing in all linux versions
« Last Edit: September 24, 2019, 20:21:24 pm by dh42 » Logged
Dragonfly
CNC Jedi
*****
Offline Offline

Posts: 2253



View Profile
« Reply #14 on: September 24, 2019, 20:25:46 pm »

While we are on Linux.
This is an old issue but I didn't bother to discuss it until now.
Under Linux the file open dialog does not show files whose extensions are in capital letters. Like 'drawing.DXF'. Also 'all files' (*.*) is missing from the selection drop-down and have to write the mask manually to show all files.
Logged
Pages: [1] 2 3
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.162 seconds with 19 queries.

Copyright © 2018 HexRay Ltd. | Sitemap