CamBam
News:
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
August 15, 2018, 21:07:28 pm


Login with username, password and session length


Pages: [1]
  Print  
Author Topic: Bug when editing point list in polyline or polyrectangle object  (Read 979 times)
Bill.yr65
CNC Ewok
*
Offline Offline

Posts: 4


View Profile
« on: June 05, 2018, 20:02:42 pm »

Version of CamBam plus [1.0] Rel 14 Linux. Polyline or polyrectangle, pointlist Points (collection) editing. When attempting to cancel an edit of a point in the collection editing screen, received an "Error setting value" Warning message. Seems reasonable since I did leave a blank field, however, clicking 'OK' does not put you back in the edit screen and you are stuck there. Tried several different escape methods, but nothing works. Can't even kill the app. The Point Edit screen and the warning message appear to be separate processes that don't shutdown when you kill the main app. I did finally get the edit screen to update the errant field by continually entering a 0 on the keyboard and banging on the OK button in the warning screen. Not a game stopper, just an annoyance.

I check this on the windows version of 9.8n and it works correctly.

Worth noting that I am have good results with 1.0 linux drawing 2d objects and generating g-code for linuxcnc. No problems so far.
Logged
dh42
Administrator
CNC Jedi
*****
Offline Offline

Posts: 5106



View Profile WWW
« Reply #1 on: June 05, 2018, 20:09:19 pm »

Hello

Yes editing point collection has a know bug on Linux versions. (no pb on Windows versions)

I think the problem is the same with 0.98 and 1.0 on Linux

http://www.cambam.co.uk/forum/index.php?topic=4447.0

++
David
Logged
Bill.yr65
CNC Ewok
*
Offline Offline

Posts: 4


View Profile
« Reply #2 on: June 05, 2018, 21:31:48 pm »

Thanks for the feedback, David.  I searched for a thread on the problem but didn't come up with anything.  Seems like a lot of folks have found the problem.  Interesting that it appears to be in mono vs CamBam directly.

Bill  Smiley
Logged
Bill.yr65
CNC Ewok
*
Offline Offline

Posts: 4


View Profile
« Reply #3 on: June 05, 2018, 22:01:24 pm »

As a follow up I updated my mono to the latest stable release.  Did solve the problem.

The latest Stable Mono release is: 5.12.0 Stable (5.12.0.226)
Logged
dh42
Administrator
CNC Jedi
*****
Offline Offline

Posts: 5106



View Profile WWW
« Reply #4 on: June 05, 2018, 22:33:40 pm »

Hello

Quote
Did solve the problem.

Nice !

I'm not at all a linux user, I just have an ubuntu 14.04 LTS installed on an old laptop to test CB. You think that the last mono is compatible with this old linux version ? ...

++
David
Logged
Bill.yr65
CNC Ewok
*
Offline Offline

Posts: 4


View Profile
« Reply #5 on: June 07, 2018, 03:17:56 am »

David, hard to say.  I'm new to this OP as well.  Best to check compatibility on the Mono web site.

Good Luck,

Bill
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.097 seconds with 19 queries.

Copyright © 2018 HexRay Ltd. | Sitemap