CamBam
News:
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 13, 2018, 12:44:31 pm


Login with username, password and session length


Pages: [1]
  Print  
Author Topic: CB R16 Linux - weird behavior  (Read 267 times)
Dragonfly
CNC Jedi
*****
Offline Offline

Posts: 2044



View Profile
« on: July 08, 2018, 15:14:05 pm »

Well, this hasn't happened before with my installation of CB.
On the attached pictures in the center there is a semi-circle and a rectangle.  I selected them both and issued 'break at intersections' command. (The intention is to make a new shape for extrusion.)
After clicking on the last OK button (tolerance dialog) the message on the first picture appeared as if CB has recieved an 'Exit' command. And the MOP properties panel became white with a red diagonal cross, i.e. - unavailable.
Repeated the same sequence of actions twice with the same result.


* CB-Error0.png (83.79 KB, 1261x1020 - viewed 44 times.)

* CB-Error.png (96.15 KB, 1713x1078 - viewed 41 times.)
Logged

Before asking a question do some effort and walk through all menus and options in CamBam.  Maybe the answer is there. Please.
Bob La Londe
CNC Jedi
*****
Offline Offline

Posts: 3418


^ 8.5 pounds on my own hand poured bait.


View Profile WWW
« Reply #1 on: July 08, 2018, 15:26:58 pm »

While not ideal, sometimes when CamBam starts acting flakey (usually after a pretty long session with a complex file) I can save the file, exit CamBam, and then restart.  
Logged

Getting started on CNC?  In or passing through my area?
If I have the time I'll be glad to show you a little in my shop. 

Some Stuff I Make with CamBam
http://www.CNCMOLDS.com
Dragonfly
CNC Jedi
*****
Offline Offline

Posts: 2044



View Profile
« Reply #2 on: July 08, 2018, 15:54:19 pm »

This is some kind of crash IMHO. And I suspect it is Mono related.
This is what I get with mono -V command
Code:
Mono JIT compiler version 5.12.0.226 (tarball Thu May  3 09:48:32 UTC 2018)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
TLS:           __thread
SIGSEGV:       altstack
Notifications: epoll
Architecture:  amd64
Disabled:      none
Misc:          softdebug
Interpreter:   yes
LLVM:          supported, not enabled.
GC:            sgen (concurrent by default)
Logged

Before asking a question do some effort and walk through all menus and options in CamBam.  Maybe the answer is there. Please.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.092 seconds with 20 queries.

Copyright © 2018 HexRay Ltd. | Sitemap