CamBam
News:
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 14, 2019, 22:13:42 pm


Login with username, password and session length


Pages: 1 [2] 3 4 5
  Print  
Author Topic: CamBam plus 0.9.8N (development release)  (Read 40986 times)
shovelhd
CNC Ewok
*
Offline Offline

Posts: 25


View Profile
« Reply #15 on: November 18, 2012, 18:00:05 pm »

Thanks 10Bulls Just what I needed
Logged
10bulls
Administrator
CNC Jedi
*****
Offline Offline

Posts: 2133


Coding Jedi


View Profile WWW
« Reply #16 on: November 19, 2012, 10:10:12 am »

Andy, I can't obtain any toolpath with the thread milling plugin with this version Wink

Sorry, the thread milling plugin needed to be modified to work with 0.9.8N.

I have uploaded a new version (1.4) here...

http://www.cambam.info/ref/plugin.threadingmop

EDIT: oops!
« Last Edit: November 19, 2012, 11:15:40 am by 10bulls » Logged
lloydsp
CNC Jedi
*****
Offline Offline

Posts: 8085



View Profile
« Reply #17 on: November 19, 2012, 11:14:11 am »

http://localhost:2300/ref/plugin.threadingmop

-----
REALLY?  Cheesy

LLoyd
Logged

"Pyro for Fun and Profit for More Than Fifty Years"
10bulls
Administrator
CNC Jedi
*****
Offline Offline

Posts: 2133


Coding Jedi


View Profile WWW
« Reply #18 on: November 19, 2012, 11:16:07 am »

REALLY?  Cheesy
Worked OK on my PC!  Tongue
Logged
lloydsp
CNC Jedi
*****
Offline Offline

Posts: 8085



View Profile
« Reply #19 on: November 19, 2012, 11:20:37 am »

I'll bet it was FAST, too!  Cheesy

LLoyd
Logged

"Pyro for Fun and Profit for More Than Fifty Years"
dh42
Administrator
CNC Jedi
*****
Offline Offline

Posts: 5677



View Profile WWW
« Reply #20 on: November 19, 2012, 18:45:40 pm »

Hello,

It work for me  Wink

Thanks
++
David
Logged
GeorgeRace
Wookie
****
Offline Offline

Posts: 294


Wobbler Engine


View Profile WWW
« Reply #21 on: November 20, 2012, 02:22:58 am »

Hi Andy and thanks for all the new functions and update.

when I start the program, if I don't hit the shift key to start in GDI, I get a pair of error messages at the bottom of the screen and it says it is using the default mode.

In that start up mode I do not get either the X or Y axis lines on the screen.  Turning them on and off from the View Menu does nothing either.

Am I missing something here?

Thanks,
George
Logged

Please check out my web site.
http://www.mykitairplane.com
Builder & Test Pilot of N73EX
Dragonfly
CNC Jedi
*****
Offline Offline

Posts: 2224



View Profile
« Reply #22 on: November 20, 2012, 09:15:17 am »

In the options menu select "OpenGL_Legacy" for the display mode and see if there's a change.  Or select "GDI" to not get error messages. I have an old nVidia card and also get these messages.
Logged
10bulls
Administrator
CNC Jedi
*****
Offline Offline

Posts: 2133


Coding Jedi


View Profile WWW
« Reply #23 on: November 20, 2012, 09:56:27 am »

Hello George,

Were you able to use OpenGL mode in the previous version?

The default behaviour is to try and start using the new 'shader' based OpenGL mode.
If this is not supported or errors are detected then it should resort to the legacy OpenGL mode and then GDI mode.

The aim is to make this selection as reliable as possible for all the varieties of video drivers out there, so it sounds like this still needs some work.

If you can send any information on the error messages that would be a big help.

As well as the error messages reported at the bottom of the CamBam window, there may be a file 'cbdebug.log' in the CamBam system folder which can be informative.

Another diagnostic that is helpful.
If you select 'Script - New - Python Script' from the top menu, then paste the following...
Code:
from CamBam.UI import OpenTkDiagnostics
OpenTkDiagnostics.OpenGLReportCaps()

Thank you very much for your help with this.
Logged
jmccracken
Droid
**
Offline Offline

Posts: 60


View Profile
« Reply #24 on: November 20, 2012, 21:02:07 pm »

Thank you for adding ball-nose compensation in the 3D Waterline Finish!
Logged
Bubba
CNC Jedi
*****
Offline Offline

Posts: 2707



View Profile
« Reply #25 on: November 20, 2012, 21:46:45 pm »

Thank you for adding ball-nose compensation in the 3D Waterline Finish!

From me to! Grin

Was much needed.. Wink
Logged

My 2ยข
kvom
CNC Jedi
*****
Offline Offline

Posts: 1541


View Profile
« Reply #26 on: November 21, 2012, 13:07:23 pm »

It wasn't in the new feature list, but the measure tool is vastly improved, as it shows the measurement directly as the mouse moves.  Props!
Logged
atwooddon
CNC Jedi
*****
Offline Offline

Posts: 629



View Profile
« Reply #27 on: November 21, 2012, 15:03:45 pm »

Just wanted to say I am impressed with the new features in 9.8N.  Have been using it since it was released and haven't had any issues.  The additional functionality all address areas I need to use and wanted.  Thanks a lot!!

Don
Logged
pixelmaker
CNC Jedi
*****
Offline Offline

Posts: 1716


View Profile WWW
« Reply #28 on: November 21, 2012, 16:54:13 pm »

Hello Andy,
my last language file for updating the language download table.


ralf

* translate_de.zip (44.2 KB - downloaded 225 times.)
Logged
GeorgeRace
Wookie
****
Offline Offline

Posts: 294


Wobbler Engine


View Profile WWW
« Reply #29 on: November 22, 2012, 15:04:33 pm »

Andy, when i selected OpenGL_Legacy in the setup menu all the problems went away.
Thanks again for the work and the new version.  Will let you know if I see anything else that does not work here.
Thanks,
George
Logged

Please check out my web site.
http://www.mykitairplane.com
Builder & Test Pilot of N73EX
Pages: 1 [2] 3 4 5
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.155 seconds with 19 queries.

Copyright © 2018 HexRay Ltd. | Sitemap